Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Netsuite Component

I'm Trying to load Transaction table into snowflake but i'm getting 'Time Out' error. All the the other tables loaded without any issue except this transaction table.
I ran the task many but same error im getting,

below is the log file data

INFO [task-thread-30] com.matillion.bi.emerald.server.snowflake.staging.JDBCQueryToSnowflake.doStage Staged [92,500] records to [ETL-656399d8-de2f-4adf-8f46-5b61858418d7]
18-Jan-2018 14:58:41.392 SEVERE [task-thread-30] com.matillion.bi.emerald.server.snowflake.staging.JDBCQueryToSnowflake.doStage An exception occurred
XcoreXnetsuiteX160X6254.ht: Timeout.

2 Community Answers

Matillion Agent  

Kalyan Arangam —

Hi Hanumanth,

Please check if adding a Timeout Connection Option helps. More about this here – https://redshiftsupport.matillion.com/customer/en/portal/articles/2396596-netsuite-query-data-model?b_id=8915#RSBNetSuite_p_Timeout.htm

In NetSuite, operations can take a very long time to return if retrieving data from child tables or in many other scenarios. Where possible, I would recommend retrieving data in batches by filtering on certain columns.

Hope that helps.

Best
Kalyan


Hanumanth Andela —

Hi Kalyan,

Thanks for your help.

I have set 'Timeout' to O but i got similar error 'Search timed out and was aborted'

The issue got resolved after i set extra connection option 'AggregateCloumMode' to 'ListAndRetrive' but it took lot of time to load.

Post Your Community Answer

To add an answer please login