Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Google Analytics

I followed the Steps and get the Client ID and Client Secret then go to Next.
Then Clicked the Authorization link, which opened a website specified Error 400.
The Error details :

Error: invalid_request
Invalid parameter value for redirect_uri: Raw IP addresses not allowed: http://3.213.172.140/oauth_redirect.html

Please suggest me to resolve the issue.

1 Community Answers

Matillion Agent  

Veronica Kupetz —

Hi Koustav,

I have responded to your original request for this issue. Please check your e-mail for the response. Here is a copy of that:

To resolve this issue, you will need to authenticate Matillion with Google using a Matillion URL that is not an IP address. Do you have a DNS name associated to your Matillion instance? If so, you would want to login to your Matillion instance using that DNS name (instead of the IP address) when initially authenticating the Matillion instance with Google for OAuth.

If your Matillion instance does not have a DNS name associated to it, you can get around this issue by updating the “Hosts” file on your local machine as described here. This will allow you to login to your Matillion instance using a URL that is not an IP address. You should then be able to authenticate Matillion with Google using the name you defined in your local hosts file. Note this is only required for the initial OAuth setup. You should be able to continue to use your IP address for Matillion moving forward. This is just required when initially setting up the OAuth profile.

Best Regards,
Veronica

Post Your Community Answer

To add an answer please login